Page 1 of 3 123 LastLast
Results 1 to 25 of 51

Thread: 91 850i limp home mode.

  1. #1
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM

    91 850i limp home mode.

    Hi guys my problem is continuing with my car. More help needed. So I finally got to the point where my car runs and drives perfect. But just after I put my new rotors and caps on the car went for a drive to see if it helped. After about 15 min driving my check engine light come on and the car went into LHM. Turned around to get home and by the time I got home it give me trans fail safe.
    It seems like that every time the car cools off it runs fine , strong on all 12. 15-20 min driving and the same thing happens. After I did a stomp test I got a 1215 code and a 2235. I'm totally clueless what to even look for at this point. I was thinking fuel pump but why is it only happens after a while of driving? Switched the coils MAF. No difference problem is still on the passenger side.
    Any ideas would be appreciated thanx.

  2. #2
    Join Date
    Apr 2009
    Location
    Vancouver Isl, BC, Canada
    Posts
    4,173
    My Cars
    09 335, 98 Evo M3, 01 M3
    know anyone that can plug you into GT1? it gives a lot more details then a stomp test does.
    Current:

    - 09 335i, JB4 G5 ISO, AFE Downpipes, AFE Stage 2 Intake, MHD BEF, Dinan Exhaust
    - 98 Euro M3, Estoril Blue
    - 01 M3, Pheonix Yellow, 6 speed coupe
    - 04 M3, Carbon Black, 6 Speed Coupe
    - 06 M5, 6pd Manual Conversion
    - 73 3.0CS, Tagia Green, 5 speed M30b35 converted

    Ex's: 1984 325e, 1988 325IX, 1992 525I, 1995 540i/6, 2002 330i, 2005 330xi, 1992 850i, 2003 330i #1, 2003 330i #2, 2002 330ci, 2004 330ci, 2007 328CI, 2007 335i

  3. #3
    Join Date
    Sep 2008
    Location
    Santa Barbara
    Posts
    2,820
    My Cars
    91 Dinan860 & 91 850 6sp
    1215 code is Mass air sensor for bank 1-6
    2235 is not a valid code....

  4. #4
    Join Date
    Dec 2009
    Location
    Devon, UK
    Posts
    232
    My Cars
    '93 e31 850, 88 e24 635
    I'll say the same thing I have to other people who've had this probem; check your fuel filters. I was having exactly the same symptoms for a couple of months before I changed them and the problem went away. Hopefully it will be that simple and you won't spend the hundreds I did trying to diagnose engine/gearbox problems!
    If I had a penny for everytime someone commented on my poor fuel economy, I'd have enough to get it to the petrol station.

  5. #5
    Join Date
    Aug 2007
    Location
    Duesseldorf, NRW, Germany
    Posts
    6,842
    My Cars
    '90 850iM70B54, '91 850i
    Quote Originally Posted by legoman67 View Post
    know anyone that can plug you into GT1? it gives a lot more details then a stomp test does.
    +1 anything else is a waste of time.

  6. #6
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM
    Unfurtunatly I don't know anyone with that gt1 tool. And the shops I use are flat out told me to don't even bring it to them because they don't have the tools or the knowledge to diagnose or work on this car.
    And about the fuel filter I have changed both of them just recently. Also changed plugs and wires, rotors and caps. Air filters and 02 sensors. Cleaned MAF throttlebody.
    So the general consent is to take it to the BMW dealer and get a diagnostics done?

  7. #7
    Join Date
    Nov 2005
    Location
    Langley BC Canada
    Posts
    2,896
    My Cars
    91 850 Panzer
    Missing from the list of things you changed recently was coils. If you know which side of the engine isnt running, swap the coils from side to side. If the problem switches sides you have a bad coil. If not, swap back and cross that possible cause off your list.
    91 850 (Panzer), 2012 Mini Cooper Countryman (WifeMobile) www.wuffer.ca


  8. #8
    Join Date
    Apr 2011
    Location
    Latvia
    Posts
    183
    My Cars
    1989 524tdA
    same shit for almost half a year, everything changed, will try to get the gt1 also to do the diagnostics.

    I can only add that I've also changed the crank postion sensors, and the pulse senders on plugs 6 and 12 no difference, all the temp sensors also new as well.

    only in my case it is the drivers side that makes this weirdness
    Last edited by riddlerLV; 07-15-2012 at 06:28 PM.

  9. #9
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM
    I did do the coils alredy, just forgot to mention it. No diferend and didint change side's. I just tryed to switch the connectors on the O2 and it only got worse soo that was good.

    I just took it to the gas station and back about 10 miles drive. Kept the car under 2000 rpm it was fine. Just before I got home I started flooring it. Seemed ok. The 4th time I floored it , did the same thing.
    This is really turning into one big nightmere. I finally got the engine running very good. And now this.

    And this 2235 code. Is weird since it dosnt exist. I just don't get it. When I changed the MAF from one side to the other I never switched it back is that could be a problem? Just guessing at this point.

  10. #10
    Join Date
    Aug 2007
    Location
    Duesseldorf, NRW, Germany
    Posts
    6,842
    My Cars
    '90 850iM70B54, '91 850i
    I also had a non existing stomp code for quite some time. At the end it was a defective O2 sensor. After I fixed that this strange code was gone.
    Since I got tired of not knowing what's going on with my engine in some cases i decided to get myself the GT1 system.
    1. Got a used Dell Latitude 630 with serial input (essential) for roughly €200,-
    2. Got an interface for €100,- IIRC
    3. All the BMW specific software I found on the web for free.
    4. Installed everything (has been the hardest part) and don't need to see the dealer anymore

    If you plan to keep your 8 and do more work on it yourself this is the way to go IMO.

  11. #11
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM
    Well in a way I don't have a choice but do the work on it my self since nobody else seems to wanna work at work on it. As of today I still would like to keep it but it's starting to frustrate me know. I just really would like to be able to enjoy it , the summers almost over and I haven't really had a chance to drive it yet. LOL. but I still keep my hopes up that I can get it running properly soon

  12. #12
    Join Date
    Apr 2011
    Location
    Latvia
    Posts
    183
    My Cars
    1989 524tdA
    serial port it is the same com port?

  13. #13
    Join Date
    Jan 2009
    Location
    France
    Posts
    448
    My Cars
    840 IA 1993
    Quote Originally Posted by riddlerLV View Post
    serial port it is the same com port?
    Yes !
    Attached Images Attached Images

  14. #14
    Join Date
    Dec 2007
    Location
    Northern Ireland
    Posts
    405
    My Cars
    1997 840ci 4.4 2000 540i

    Cool

    Quote Originally Posted by wokke View Post
    I also had a non existing stomp code for quite some time. At the end it was a defective O2 sensor. After I fixed that this strange code was gone.
    Since I got tired of not knowing what's going on with my engine in some cases i decided to get myself the GT1 system.
    1. Got a used Dell Latitude 630 with serial input (essential) for roughly €200,-
    2. Got an interface for €100,- IIRC
    3. All the BMW specific software I found on the web for free.
    4. Installed everything (has been the hardest part) and don't need to see the dealer anymore

    If you plan to keep your 8 and do more work on it yourself this is the way to go IMO.
    What software have you got and where can I get it please

    Hi I just purchased this ready cheap You should buy one and test the car yourself

    http://www.autoobd2.co.uk/wholesale/...t-65-1062.html
    Last edited by Winkie; 07-16-2012 at 08:54 PM.
    8 Series Never Ending

  15. #15
    Join Date
    Apr 2011
    Location
    Latvia
    Posts
    183
    My Cars
    1989 524tdA
    Quote Originally Posted by Frenchman840 View Post
    Yes !

    I have an old IBM laptop with this port, + interface to work with also, Inpa can acces most bmws but not the e32 or e31, (e31 with lots of errors) so then all that matters is the correct software.

  16. #16
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM
    What do you guys think could it be a weak or bad battery causing all my problems?
    I'm really on my own on this one. I called bmw and they basically said that they don't have any mechanics that are experienced with this vehicles. So they can't say they will and how fast can find the problem. So after that I called one of the most reputable import shop in the city told them what I have and what kind of problems I have thay said that don't even bring it to them because they don't wanna work on it at all. So at this point I really need you guys help with this. I don't want to turn this beautiful car into a lawn ornament.

  17. #17
    Join Date
    Sep 2008
    Location
    Santa Barbara
    Posts
    2,820
    My Cars
    91 Dinan860 & 91 850 6sp
    ask these guys for a recommended independent shop info@bmwpower.ca
    That's the BMW club of Manitoba...
    Birchwood BMW most certainly has the diagnostic equipment, but if they don't have a trained monkey... dunno what to say.

  18. #18
    Join Date
    Apr 2011
    Location
    Latvia
    Posts
    183
    My Cars
    1989 524tdA
    I am taking mine to an experienced electrician, if he doesn't find any thing all the M70 electronic shit goes, m73 electronics from e38 will be installed instead, completely sick of this limp mode. the m73 at least can be diagnosed more widely + around here lots of ecu sets are available if mine do go bad some day

  19. #19
    Join Date
    Aug 2007
    Location
    Duesseldorf, NRW, Germany
    Posts
    6,842
    My Cars
    '90 850iM70B54, '91 850i
    Quote Originally Posted by riddlerLV View Post
    I am taking mine to an experienced electrician, if he doesn't find any thing all the M70 electronic shit goes, m73 electronics from e38 will be installed instead, completely sick of this limp mode. the m73 at least can be diagnosed more widely + around here lots of ecu sets are available if mine do go bad some day

    I assume you have an M73 installed - otherwise have fun

  20. #20
    Join Date
    Sep 2008
    Location
    Santa Barbara
    Posts
    2,820
    My Cars
    91 Dinan860 & 91 850 6sp
    Quote Originally Posted by wokke View Post
    I assume you have an M73 installed - otherwise have fun

    I think he already has a Frankenmotor like the one you are creating in your lab

  21. #21
    Join Date
    Jun 2009
    Location
    Canada
    Posts
    473
    My Cars
    95 BMW 850
    Maybe the OP should take his car to Frank (N) Motors. They've worked on the E31. Or take it to Birchwood BMW.
    Last edited by llcarlos; 07-18-2012 at 03:39 PM.

  22. #22
    Join Date
    Oct 2010
    Location
    Divinópolis-MG Brazil
    Posts
    189
    My Cars
    BMW 850CI 1993
    Check the relays of the fuel pumps located in the engine bay on the right. There are also relays the DME, see if it's ok. Fuel pumps may have intermittent faults, especially after an operation time of the car. Check the pressure of the pumps or replace them in position, if the failure to switch sides, the problem is the pump. How the whip is the engine of your car?

  23. #23
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM
    Hi guys Frank motors said not to bring it to them and Birchwood BMW wants basically an open check book before they look at it. And that's not an option eighter.

    There is an update tho.
    After I switched the fuel lines @ the filter I decided to put everything else back to where they are supposd to be. So I switched the fuel lines back , the coils , and the MaF's.
    And since all my trouble started after replacing the rotors and caps, I decited to take thge cap of the pass side. And I found that the brand new cap on one spot it seems like it was rubbing on something on the inside to the point where I had a bunch of filing inside and the plastic got paper thin on one spot with almost starting to have a hole on it. I have no idea how that could happen. So I put one of the old cap back on.
    After starting the car it ran exellent , I took it for a drive, drove fine. So I started to drive it hard and it was great. So after a half Hour driving/ beating on it , I got a check engine light. No limp mode both banks are running but it revs very slow and my tranny shifts hard. After coooling of it was ok again for a bit before I got the light back on. Stomp code is 1215 and 2222. Idle good no missfire , everything seems to be good just very slow reving.
    Now any new ideas?

    If I take the dk motors out do I need something special seal or gasket to put them back in?
    Thanx for any input.

  24. #24
    Join Date
    Aug 2007
    Location
    Duesseldorf, NRW, Germany
    Posts
    6,842
    My Cars
    '90 850iM70B54, '91 850i
    Before playing in another area you should find the root cause for the cap issue. Just replacing the mechanically defective cap with another one is no solution. Find out the WHAT and WHY on the old cap's damage. Sounds to me like you are finally on the right track. So stick to it. What does the rotor look like? Is it tight on the metal plate? Is the metal plate securely fastened to the cam shaft? These are the things I'd check now.

  25. #25
    Join Date
    Jun 2012
    Location
    Winnipeg Mb. Canada
    Posts
    65
    My Cars
    2004 BMW 545i 6MT. 91 BM
    The rotor looked fine no damage , and the damage on the cap could not be caused by the cap. I'm thinking maybe a defective cap. There isint anything in there that spinning. Is there?

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •